All systems operational

Some disruptions to WhatsApp API and 360dialog Hub

Resolved
Operational
Started about 1 year ago Lasted about 6 hours

Affected

360dialog Infrastructure
360dialog WhatsApp Business API
WhatsApp Business API Number Setup
360dialog Partner Hub
Partner API
Partner Webhooks
Updates
  • Resolved
    Resolved

    Our engineering team has deployed the fix for the 360dialog Hub UI issue presented and now all systems are operational.

    We will keep monitoring its behavior to ensure it is stable and will provide an update in the upcoming hours.

    Root Cause Analysis

    Issue description and impact:
    On 11/04/23 at ~10:50 UTC we detected a disruption to our core services. Specifically, calls to our WhatsApp and 360dialog Hub APIs were timing out. Our web application, the 360dialog Hub, could not be loaded.

    Cause of the issue:
    A malfunction in our Redis based caching service caused by a bug in the software.

    Mitigation Steps / Summary:
    Our engineering team applied patches which mitigated the issue as per the summary below.

    360dialog Hub - Partners webservice
    5 hours and 24 minutes
    10:50-16:14 UTC

    360dialog Hub - Other services
    3 hours and 7 minutes
    10:50-13:57 UTC

    Messaging Waba proxy callback and Waba proxy webserver
    1 hour and 48 minutes
    10:50-12:38 UTC
    (partial outage)

    Prevention of recurrence & suggestions:
    We have completed an internal review with all relevant teams and work is underway to strengthen our deployment protocols to prevent recurrence.

  • Identified
    Update

    We are aware that the 360dialog Hub UI is still inaccessible for many Customers. Our engineering teams are working on a solution for this. We will provide another update within 2 hours or sooner if additional information is available.

  • Identified
    Update

    We are aware that the 360dialog Hub UI is still inaccessible for many Customers. Our engineering teams are working on a solution for this. We will provide another update within 2 hours or sooner if additional information is available.

  • Identified
    Update

    The WhatsApp API has been restored ✅
    We are working to resolve the issues with the 360dialog Hub currently.

  • Identified
    Update

    Our engineers are working on a solution for the outage. We will update again asap.

  • Identified
    Identified

    Our engineers have identified the cause of the issue.

  • Investigating
    Investigating

    We are aware of an issue that is impacting our WhatsApp API and 360dialog Hub. Our engineering team is currently investigating it and we'll update again as soon as possible.

    When attempting to send messages, you will get the error: 500 Internal Server Error
    When trying to load the 360dialog Hub or calling any hub.360dialog.com/v1 endpoint, you will get the error: 504 Gateway Time-out