All systems operational

Resolved
Some disruptions to WABA Management > Payment Method

Started
July 06, 2023 at 7:42 AM
Status
Resolved after 1 day

Impact

Degraded performance
Affected
Meta Infrastructure
WhatsApp Business Account Management (FB Business Manager)
  • Resolved

    The issue is now resolved.

  • Identified

    We are aware of an issue that is impacting our ability to set payment methods on new WhatsApp Business Accounts. We have escalated the issue to Meta and we are awaiting on a solution from their Integration Support Engineering team.

    This issue may affect new WABAs onboarded after 05/July/2023.

    When the issue is fixed by Meta, we will retrospectively set the Payment Methods on any affected WABAs.