360dialog - Application request limit reached – Incident details

All systems operational

Application request limit reached

Resolved
Degraded performance
Started 22 days agoLasted 6 days

Affected

360dialog Infrastructure

Degraded performance from 1:02 PM to 1:37 PM, Operational from 1:37 PM to 1:57 PM, Degraded performance from 1:57 PM to 2:20 PM, Operational from 2:20 PM to 10:21 AM

360dialog WhatsApp Business API

Degraded performance from 1:02 PM to 1:37 PM, Operational from 1:37 PM to 1:57 PM, Degraded performance from 1:57 PM to 2:20 PM, Operational from 2:20 PM to 10:21 AM

360dialog Client Hub

Degraded performance from 1:02 PM to 1:37 PM, Operational from 1:37 PM to 1:57 PM, Degraded performance from 1:57 PM to 2:20 PM, Operational from 2:20 PM to 10:21 AM

360dialog Partner Hub

Degraded performance from 1:02 PM to 1:37 PM, Operational from 1:37 PM to 1:57 PM, Degraded performance from 1:57 PM to 2:20 PM, Operational from 2:20 PM to 10:21 AM

Partner API

Degraded performance from 1:02 PM to 1:37 PM, Operational from 1:37 PM to 1:57 PM, Degraded performance from 1:57 PM to 2:20 PM, Operational from 2:20 PM to 10:21 AM

Updates
  • Resolved
    Resolved

    Meta have applied an exception to our app.
    (The exception was incorrectly applied on Fri 27/09/24 but the issue was fixed by Meta's engineering team). We do not expect the issue to re-occur.

    360dialog - Root Cause Analysis 

    Issue description and impact:

    On 12th Sept 2024  ~14:45 utc+1, waba management operations were blocked: 

    • Template creation

    • Template syncing

    • Number registration

    • WABA profile management

    • Migrations

    • Onboarding

    • Channel updates


    Cause of the issue:

    The issue arose due to Meta setting the rate limit for one of our applications too low. This threshold, controlled and enforced at the application level by Meta, led to a disruption in our service. This happened because 360dialog has significantly more active WABAs than any other BSP and Meta has failed to apply proper limits according to our strong growth. While we strive to maintain optimal performance, the constraints set by Meta directly impacted the functionality of our application in this instance.


    Mitigation Steps:

    Sept 12, 14:45 - Issue started

    Sept 13, 07:46 - Issue escalated to Meta

    Sept 13, 15:20 - Attempted fix

    No response from Meta

    Sept 14, 13:32 - Initiated workaround

    Sept 14, 15:40 - App unblocked. Issue mitigated temporarily.

    Sept 16, 06:51 - Issue re-occurs

    Sept 16, 13:30 - Meta provides support that results in root cause diagnosis

    Sept 16, 14:46 - Issue mitigated temporarily

    Sept 25, 12:55 - Issue re-occurred

    Sept 27, 13:30 - Workaround measure deployed

    Sept 27, 15:10 - Issue mitigated temporarily

    Sept 27, 17:00 - Meta confirm they applied an exception to our app

    Sept 30, 14:23 - Issue reoccurs

    Sept 30, 16:53 - Meta confirmed the exception was not applied correctly on their side but they fixed it. 

    Issue Resolved


    Prevention of recurrence & suggestions:

    We have obtained an adequate rate limit again and are working with Meta on a process to increase our limit accordingly to our growth in the future. Additionally we have completed an internal review with relevant teams & stakeholders and we’re working on adjusting our system architecture to accommodate Meta’s app rate limiting practices. 

    Separately, Meta is conducting a thorough investigation to understand where the escalation process failed and how they can improve it, particularly during weekends. 


  • Monitoring
    Monitoring

    Template message creation and profile photo upload functionality has been restored.

    We are continuing to monitor the situation with Meta support.

  • Identified
    Identified

    We are aware that the issue is re-occurring and is affecting some WABA operations including:

    • Profile photo upload

    • Template message creation with header_handle and/or header_url

    We are in contact with Meta about the issue and the case is escalated with their relevant stakeholders.

    We will provide another update in 4 hours or sooner if we have a significant development.

  • Monitoring
    Update

    Template message creation and profile photo upload functionality has been restored.

    We are continuing to monitor the situation with Meta support.

  • Monitoring
    Update

    We are continuing to work with Meta Engineering team on this issue.

    The below actions are still affected:

    • Cloud API profile photo upload

    • Template message creation with header_handle and/or header_url

    We will provide another update regards the status.

  • Monitoring
    Update

    Our Engineering team is still working on a fix to make the below actions available:

    • Cloud API profile photo upload

    • Template message creation with header_handle and/or header_url

    We will provide another update regards the status.

  • Monitoring
    Update

    We are continuing to work on the below as this actions are still affected:

    • Cloud API profile photo upload

    • Template message creation with header_handle and/or header_url

    We will share another update when this is resolved.

  • Monitoring
    Monitoring

    The majority of functionality has been restored to normal.

    However, the below actions are still affected and we are working to restore full functionality

    • Cloud API profile photo upload

    • Template message creation with header_handle and/or header_url

    We will share another update when this is resolved.

  • Investigating
    Update

    We are continuing to work on this problem, and do not currently have an ETA for restoration of all functionality.

  • Investigating
    Investigating

    Our communication channel with META have reached the limit of incorrect requests. In this case 360dialog Hub or our API will produce errors for the following actions:

    - editing or submitting templates
    - migrations
    - onboarding
    - flows
    - hosting type change

    You can use Meta Business Manager as a workaround for creating and submitting templates.

    Messaging functionality is performing normally.

    We are continuing to work on this problem.