All systems operational

Resolved
Meta issue impacting Business' Display Names

Started
July 17, 2023 at 5:43 PM
Status
Resolved after 3 days

Impact

Degraded performance
Affected
Meta Infrastructure
WhatsApp Business Account Management (FB Business Manager)
  • Resolved

    Meta have resolved this issue.
    The WhatsApp Business Account Management service is up and running with no known issues.

  • Investigating

    Meta are currently experiencing major disruption impacting the Business' Display Names on WhatsApp Business API. This issue started at July 13th, 12:14 p.m UTC. Meta engineering teams are investigating the issue.

    See Meta's Status page for more information and updates