- - Meta Incident - PDF Messages Not Delivering Webhooks (Feb 2025) – Incident details

All systems operational

Meta Incident - PDF Messages Not Delivering Webhooks (Feb 2025)

Resolved
Degraded performance
Started about 1 month agoLasted less than a minute

Affected

Meta Infrastructure

Operational from 7:03 PM to 12:00 PM, Degraded performance from 12:00 PM to 7:03 PM

WhatsApp Cloud API (Message Delivery)

Operational from 7:03 PM to 12:00 PM, Degraded performance from 12:00 PM to 7:03 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    Summary
    Between February 4 and February 11, 2025, Meta identified an issue affecting incoming webhook delivery for a small subset of PDF messages sent via WhatsApp Web. Certain PDFs failed to generate incoming message webhooks for Cloud API partners due to an internal change in PDF thumbnail generation, which produced thumbnails exceeding Cloud API size limits. Outgoing messages and messages sent from Android or iOS clients were not impacted.

    Impact
    A very low volume of incoming PDF messages sent via WhatsApp Web were not delivered through Cloud API webhooks. Business messaging functionality and 360dialog platform operations remained fully operational.

    Resolution
    Meta acknowledged the issue, reverted the thumbnail generation change, and deployed a fix on February 11, 2025 at 00:03 UTC, after which normal webhook delivery resumed.

    Prevention
    Meta implemented additional testing, monitoring, and platform consistency checks to prevent recurrence.

    This was a Meta incident and was not related to 360dialog systems or infrastructure.